dau.cc
  Startseite Registrieren Kalender Mitglieder Suche FAQ Arcade Bilder Portal  

dau.cc » News und Allgemeines » Support » Lightbox im Konqueror » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Thema ist geschlossen
Zum Ende der Seite springen Lightbox im Konqueror
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »

wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96558
Lightbox im Konqueror 13.08.2008 12:51 [OPTIONEN] [TOP] [DOWN]

Also erstmal steht in dieser Forenbeschreibung "...W??nsche...". D
Dann hab' ich hier im Konqueror ein Problem mit dieser (veralteten?) Lightboxversion.
Beim oeffnen eines Bildes wird mir der weisze Balken mit dem Closebutton abgeschwaerzt, und beim zweiten Bild pro Session ist das ganze Bild schwarz.

Ich weiss, dass wahrscheinlich nicht viele onesworld User Konqueror verwenden, aber ich meld's Mal vorsichtshalber.


SSLK
one one ist männlich
Dauministrator


images/avatars/avatar-1104.jpg

Dabei seit: 21.09.2005

Post ID: 96560
13.08.2008 12:53 [OPTIONEN] [TOP] [DOWN]

Das "Wünsche" hab ich ausgebessert, sind halt noch so kleine Altlasten vom Rückumzug. Wenn so ne Datenbank so oft umzieht.. naja, egal.

Das Problem mit der Lightbox kann ich leider nicht reproduzieren, da ich den Konqueror nicht nutze. Wichtig ist, eine Seite komplett ausladen zu lassen, bevor man auf das Bild klickt, denn das Script für die Lightbox wird erst ganz am Schluss geladen.

Vielleicht ist west heute abend mal so nett und testet das, ich glaub der hat den Browser.
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96564
Themenstarter Thema begonnen von wolvieh
13.08.2008 13:37 [OPTIONEN] [TOP] [DOWN]

Bei der neuen Lightbox Version muss auch die Seite nicht mehr fertig geladen sein, das waer auch ein groszer Vorteil...


SSLK
one one ist männlich
Dauministrator


images/avatars/avatar-1104.jpg

Dabei seit: 21.09.2005

Post ID: 96566
13.08.2008 13:41 [OPTIONEN] [TOP] [DOWN]

Es ist ein ziemlicher Akt, die im wbb anzupassen und nach Möglichkeit bleibt die in der Version.
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96568
Themenstarter Thema begonnen von wolvieh
13.08.2008 13:47 [OPTIONEN] [TOP] [DOWN]

Bist dir sicher? Muss man da nicht nur den Lightbox Ordner ersetzen und den Code in der headinclude ein bisschen anpassen? Der Befehl zum Aufrufen bei einem Attachment bleibt eh gleich, es kommt nur ein Woertchen im Javascript dazu...


SSLK

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von wolvieh: 13.08.2008 13:48.

one one ist männlich
Dauministrator


images/avatars/avatar-1104.jpg

Dabei seit: 21.09.2005

Post ID: 96569
13.08.2008 13:54 [OPTIONEN] [TOP] [DOWN]

Wieviele wbbs hattest du schon? ugly

Die Lightbox funktioniert hier z.B. auch bei Dateianhängen, nicht nur bei eingebundenen Bildern.
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96571
Themenstarter Thema begonnen von wolvieh
13.08.2008 14:26 [OPTIONEN] [TOP] [DOWN]

Unabhaengig davon, wieviele WBBs ich schon hatte oder nicht, ermoeglicht mir ein letztes Quaentchen gesunder Menschenverstand, eine ungefaehre Vorstellung davon zu haben, wie Lightbox ungefaehr in ein WBB integriert wird.

Die erste Moeglichkeit waere, das Lightbox Script herzunehmen, und ein komplettes WBB darum herumzucoden. Dann waere der Aufwand vermutlich wirklich hoch. Diese Variante schliesze ich schon Mal von vornherein aus.

Dann koennte man noch das Lightbox Script hernehmen, und es in ein WBB integrieren. Das wuerde ungefaehr so ablaufen: Lightbox wird in das Rootverzeichnis des Boards hochgeladen, das Javascript pro Style in ein Template eingebunden, das auf jeder Seite geladen wird (headinclude z.B.), und in der attachments.php oder wie auch immer die Datei heiszen mag, wird der Code zum Aufruf eines Attachments fuer Lightbox angepasst. Zum Einbinden eines Bildes wird auch dieser BBCode fuer Lightbox modifiziert.

Da sich am Aufrufen von Lightbox nichts geaendert hat, fallen die Anpassungen fuer den BBCode und den Attachmentaufruf schon Mal weg, es bleiben also noch das Hinzufuegen eines Wortes in ein Template pro Style und das Aktualisieren des Lightbox Ordners.

Korrigiert mich, wenn ich falsch liege...


SSLK
one one ist männlich
Dauministrator


images/avatars/avatar-1104.jpg

Dabei seit: 21.09.2005

Post ID: 96572
13.08.2008 14:36 [OPTIONEN] [TOP] [DOWN]

Du liegst momentan nur bei einer Sache falsch:

Du bist der einzige, bei dem das momentan nicht funktioniert und ich werde aufgrund einer wagen Vermutung nicht sonstwas ändern.

Lass uns einfach warten, bis west sich das unter Linux mit dem Konquerer angesehen hat. Ich denke einfach mal, der macht das heute abend.
gamerphil gamerphil ist männlich
Uni-Banause


images/avatars/avatar-1035.png

Dabei seit: 31.05.2007

Post ID: 96580
13.08.2008 14:59 [OPTIONEN] [TOP] [DOWN]

Allerdings ist es schon ein enormer Vorteil, wenn man die Seite nicht mehr ausladen muss. Klar bei dir mit dsl6000 ist das kein Ding. Dsl2000 brauch bei vielen Bildern halt ein bisschen länger und die ersten Bilder sind schon da während die letzten noch laden.

Habe gerade nochmal nachgeguckt. Es müssen nur die Dateien ausgetauscht werden.

An der Funktionsweise hat sich nichts geändert. Welches Wort soll denn dazugekommen sein?
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96582
Themenstarter Thema begonnen von wolvieh
13.08.2008 15:09 [OPTIONEN] [TOP] [DOWN]

In der Zeile
code:
1:
<script type="text/javascript" src="Bildflash/js/scriptaculous.js?load=effects"></script>
muss man iirc
code:
1:
load=effects
mit
code:
1:
load=effects,builder
ersetzen.

Könnte aber auch ohne die Änderung funktionieren, ich hab' ja keine Ahnung, was das Script macht. D

/edit: Ich seh' grad, hauptsache in der Lightbox gibt's ein scharfes S. Muahaha. yeah2


SSLK

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von wolvieh: 13.08.2008 15:15.

gamerphil gamerphil ist männlich
Uni-Banause


images/avatars/avatar-1035.png

Dabei seit: 31.05.2007

Post ID: 96586
13.08.2008 15:18 [OPTIONEN] [TOP] [DOWN]

ok hab gedacht das wäre vorher schon so gewesen...

Ich glaube sobald diese Angabe da ist, wird NUR das jeweilige Script mit geladen.

D.h. wenn one, dass ?effects weggelassen hätte, würde das immer noch gehen, hätte aber die ganze zeit mehr Traffic gekostet D
Machiavelli
Heide


images/avatars/avatar-1077.jpg

Dabei seit: 30.09.2005

Post ID: 96591
13.08.2008 15:55 [OPTIONEN] [TOP] [DOWN]

Wat für Browser werden denn hier verwendet? Auch unter Linux laufen richtige Brower, wie zum Beispiel das Füchslein... bleh

Ansonsten, ich habe extra mal dat Viech ausprobiert... saludo

wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96592
Themenstarter Thema begonnen von wolvieh
13.08.2008 16:05 [OPTIONEN] [TOP] [DOWN]

Danke, welche Version verwendest du? Hast du mehrere Bilder getestet oder nur eines?


SSLK
Machiavelli
Heide


images/avatars/avatar-1077.jpg

Dabei seit: 30.09.2005

Post ID: 96593
13.08.2008 16:09 [OPTIONEN] [TOP] [DOWN]

Die 3.5.9 habe ich gerade am Laufen. In dem Tab davor war auch ein Bild in einem anderen Thread in der Lightbox geöffnet.
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96594
Themenstarter Thema begonnen von wolvieh
13.08.2008 16:14 [OPTIONEN] [TOP] [DOWN]

Und welche Javaversion hast du am Laufen?
Hm, vielleicht liegt's an 4.1, aber mit der neusten Lightbox funktioniert's einwandfrei.


SSLK
one one ist männlich
Dauministrator


images/avatars/avatar-1104.jpg

Dabei seit: 21.09.2005

Post ID: 96596
13.08.2008 16:18 [OPTIONEN] [TOP] [DOWN]

Mit der alten ja scheinbar auch. So wie ich das hier rauslese liegt es an dir und nicht an der Software hier. P

Ergo: Lightbox bleibt wie sie ist.
Machiavelli
Heide


images/avatars/avatar-1077.jpg

Dabei seit: 30.09.2005

Post ID: 96599
13.08.2008 16:28 [OPTIONEN] [TOP] [DOWN]

Bezüglich Java steht das Ubuntu noch bei der installierten Version 1.5.0. Hmhm... 4 ist ja auch noch nicht stable... D
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96622
Themenstarter Thema begonnen von wolvieh
13.08.2008 17:41 [OPTIONEN] [TOP] [DOWN]

Natürlich war KDE 4 nicht stable, 4.1 wird aber schon ziemlich stark benutzt, sogar Kubuntu bietet ein Image mit 4.1 an. Konqueror läuft hier besser und schneller als je zuvor.

Wie auch immer, es ist mir ja egal. Ich hab' nur berichtet, was ich beobachtet habe. Auf einer anderen Website hat die alte Lightboxversion nicht mehr funktioniert, als die neue Version installiert wurde jedoch schon, sogar mit halbgeladenen Grafiken.

Ich wundere mich nur, warum die Entwickler eine neue Version herausgegeben haben, wenn die Alte bei allen (ausser ja bei mir) so wunderbar funktioniert.


SSLK
one one ist männlich
Dauministrator


images/avatars/avatar-1104.jpg

Dabei seit: 21.09.2005

Post ID: 96623
13.08.2008 17:46 [OPTIONEN] [TOP] [DOWN]

Eine neue Version bedeutet aber nicht, dass die alte nicht mehr funktioniert. Eine neue Version bedeutet nichtmals, dass sie besser als die alte ist. Siehe Firefox 3 zum Beispiel. Viele schwören immer noch auf den 2er, was ich auch nachvollziehen kann. Das wbb3 ist auch scheisse, noch son Beispiel. Der IE kann ab Version 7 kein html mehr, was ist daran besser?

Fakt ist:

Bei dir funktioniert sie nicht.

Machiavelli hat sie mit dem Konquerer getestet (unter Linux) und bei ihm funktioniert sie problemlos.

Ich sehe daher keinen Grund, das Problem hier zu suchen. Das Problem wird, auch wenn du es scheinbar nicht hören magst, bei dir liegen und nicht bei uns.

Ich hoffe, west wird das auch noch testen, um das nochmal zu bestätigen aber sei froh, dass ich kein Linux nutze.
wolvieh
Why So Serious?


images/avatars/avatar-592.jpg

Dabei seit: 20.01.2008

Post ID: 96624
Themenstarter Thema begonnen von wolvieh
13.08.2008 18:09 [OPTIONEN] [TOP] [DOWN]

Zitat:
Original von one am 13. August 2008, 17:46 Uhr
Eine neue Version bedeutet aber nicht, dass die alte nicht mehr funktioniert. Eine neue Version bedeutet nichtmals, dass sie besser als die alte ist. Siehe Firefox 3 zum Beispiel. Viele schwören immer noch auf den 2er, was ich auch nachvollziehen kann. Das wbb3 ist auch scheisse, noch son Beispiel. Der IE kann ab Version 7 kein html mehr, was ist daran besser?
Der Unterschied ist, dass Lightbox keine umwerfenden neuen Funktionen bekommen hat, sonder lediglich ein paar Bugfixes erhalten hat.
Dass der IE 7 kein HTML kann ist doch kompletter Mist, was soll das bitte bedeuten? Dass alle Seiten, die in HTML geschrieben wurden, nicht mehr angezeigt werden koennen? Es stimmt natuerlich, dass der Internet Explorer einschlieszlich der Version 7 keine aktuellen Webstandards wie xHTML und CSS unterstuetzt, aber schlimmer geworden ist es imho nicht. Vor allem kann der IE 6 keine Transparenz in PNGs, also muss der durchschnittliche Webdesigner GIFs einbauen oder kann nur einfärbige Hintergründe verwenden.
Zitat:
Ich sehe daher keinen Grund, das Problem hier zu suchen. Das Problem wird, auch wenn du es scheinbar nicht hören magst, bei dir liegen und nicht bei uns.
Was ich vorher vergessen habe: Ich hab nur berichtet, was ich beobachtet habe, und nicht verlangt, dass die Lightbox geupdated wird. Das war auch nur ein Vorschlag, keine Bitte und schon gar keine Aufforderung.
Zitat:
Ich hoffe, west wird das auch noch testen, um das nochmal zu bestätigen aber sei froh, dass ich kein Linux nutze.
Ich werd' wieder bereuen, das gefragt zu haben aber: Warum? Weil dann die Linux Community noch einen User haette, der sich nach einer Stunde mit einem "Linux ist scheisze, meine Windowstaste funktioniert nicht" Thread im ubuntuusers.de Forum verabschieden wuerde?


SSLK
Seiten (2): [1] 2 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Thema ist geschlossen
dau.cc » News und Allgemeines » Support » Lightbox im Konqueror

Archiv | Team | Suchen | Hilfe | Impressum